Symptom
Upon trying to make the required changes to the Business Partner and saving the changes, you receive the error:
Data set ADDR_ICOMM for BP TEL maintained time-dependently,despite inact.time dep.
(OR)
Data set ADDR_ICOMM for BP SMTP maintained time-dependently,despite inact.time dep.
Diagnosis
You have attempted to access a business partner for which time-dependent data has already been maintained, although the time dependency for this data set has been deactivated.
System Response
In this situation, accessing the business partner in change mode leads to a termination.
Procedure
To be able to process the data of this business partner again, you must activate the time dependency for this data set in Customizing of the SAP Business Partner.
Choose Customizing in the toolbar of the Performance Assistant in order to navigate in the Customizing.
For more information, see SAP note 810634.
Message no. R11349
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to Manage Business Partner Master Data app
- Find and Open the Business Partner ID
- Select Edit
- Make the required changes
- Select Apply
- Select Save
- System throws the error
Cause
- For the error: Data set ADDR_ICOMM for BP TEL maintained time-dependently,despite inact.time dep.
In the Business Partner, there is a Telephone number/ Cell Phone number which is maintained in the tab Address Independent Communication. - For the error: Data set ADDR_ICOMM for BP SMTP maintained time-dependently,despite inact.time dep.
In the Business Partner, there is an Email which is maintained in the tab Address Independent Communication.
The above errors occur due to Valid From date entry for the Address Independent Telephone number/ Cell Phone number/ Email data respectively. The Valid From date should be empty according to TB056 customizing and there is no provision for user to enter this date via Fiori app or BP transaction. Currently, there is no SSCUI available for customer to change the TB056 customizing.
For the Business Partner, the Valid From date was not empty for some unknown reason and it was causing the issue during Save.
Resolution
Using the Maintain Business Partner App, you can delete the Address Independent data Telephone number/ Cell Phone number/ Email
- Go to the app Maintain Business Partner Master Data
- Go to the tab Address Independent data
- Select the entry which ever is relevant in your case Telephone number/ Cell Phone number/ Email data
- Select Delete
- Select Save
Thereafter, recreate the data which you deleted and Save the changes to the Business Partner.
- Go to the app Maintain Business Partner Master Data
- Go to the tab Address Independent data
- Go to the section Telephone number/ Cell Phone number/ Email data
- Select Create
- Add the required data
- Select Save
Keywords
SAP S/4HANA Cloud, LO-MD-BP, Time Dependency, ADDR_ICOMM, Business Partner, time-dependently, R11349, inact.time dep , KBA , AP-MD-BP , Business Partner , Problem