Symptom
- The Actual Quantity field for a Service Item displays a dash "-" instead of a 0 after initial save
- Users are unable to change the value to "0" after the initial entry
- In some scenarios, the customer needs to enter a value of "zero" 0, but the value is not accepted and it is then erased
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Reproducing the Issue
- Go to Services -> Tickets
- Open or create a new ticket
- Go to Items
- Click "Add" to add a new product
- Enter the Product, Description, Plan Quantity with a value other than zero "0" and enter the Actual Quantity with "0"
- Click "Add" and then Save
Cause
- Technically speaking, 0 is not a value that should be counted since the system will recognize it as null.
- The system is working as designed
Resolution
- This is the standard behavior of the system.
- On initial entry, the system will not display the zero "0" as a value if the value was null to begin with
- If the original value entered was greater than zero "0", for example 1, then the system will allow the user to change the value to "0" sub-sequently since it now leaves the change optional
- If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
See Also
2669649 - Actual Quantity Setting the Status of the Item to Started
Keywords
Actual Quantity field from a Service Item, Quantity, Products, , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications 2205