Symptom
When in Admin Center > Manage Templates, a Job Requisition template cannot be opened and throws an application error when clicking on it.
Error is similar to this (same fingerprint):
errorId=a61679fa-a1e9-42a2-b8df-a867f322be02, fingerprint=f67ee7dd2d3dc41529b44c361fa480b013d5c628, timestamp=2022-07-19T10:30:25.717+0200, errorMessage=An application error occurred. Please try again later, or notify support (with the error information of errorId=a61679fa-a1e9-42a2-b8df-a867f322be02, timestamp=2022-07-19T10:30:25.717+0200, and the version information from the current screen) if the issue keeps occurring.,[...]
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Admin Center > Manage Templates
- Click on the Recruiting Management tab
- Select Job Requisition category
- Click on a template to open it
- Receive the error above
Cause
This is caused by a "default-value" being incorrectly specified on a field that does not allow it.
For example: id="numberOpenings" <default-value>1.0</default-value>
Resolution
As per this KBA, a default value can only be specified on the fields "defaultLanguage" and "currency" for Job Requisition templates.
Removing the incorrect "default-value" entry in the xml template will resolve the error. Note that this needs to be done from Provisioning using the xml template as the template cannot be accessed from Manage Templates. A partner's assistance will be required for customers who don't have access to Provisioning.
See Also
Keywords
Manage Templates, job requisition, error, f67ee7dd2d3dc41529b44c361fa480b013d5c628, 2c66eee018c284415d75c61c384fcc8d2e7d0393 , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , Problem