Symptom
No output is getting generated when you submit a quote and therefore the 'Set to Won' action does not become active.
Environment
SAP Cloud for Customer
Reproducing the Issue
Since the reproduction of this issue involves customization, there is not just one way to reproduce this.
Cause
When calling the SUBMIT action, some BO fields are changed. This could happen for example by extension fields which might get changed (as example) by a field update via workflow rule.
Resolution
Please be aware that the Output can only be triggered when the quote data stays unchanged during the Submit call.
To avoid reset of the output status and thus make the output possible, there are following options:
Option 1: Implement a PDI action which triggers at first all necessary quote changes, and then, as last step, calls the standard SUBMIT action
Option 2: Enable the BC scope question: ‘Do you want to control the reset of the approval status and output status via workflow rules?’ to deactivate automatic reset of the output status. For reset of the output status, a workflow rule needs to be additionally defined (s. the online description for the BC question)
However please note that for sales quotes with bidirectional replication, it does not really make sense to set quote to Won even if possible. Because the ERP is leading system for the bidi integration scenario and ignores the status change on the C4C side. This means even the status is set to won in C4C (just the same if manually or via workflow), the status can only stay for some seconds and will then be replaced by the status coming from the ERP.
See Also
KBA 3196389 - 'Set to Won' Action is Grayed out for Replicated Sales Quotes
Keywords
Set to Won; greyed ; Output; Submit , KBA , output missing , LOD-LE-CQP , Customer Quote Processing , Problem