Symptom
- Cloud Print Manager (CPM) for Pull Integration was configured.
- The print queue is returning the status 'Failed' randomly for a print request. If the process is repeated, the print request might work without issues.
- The following error message can be seen in the CPM logs:
(xx.xx.xxxx xx:xx:xx) *** ERROR *** [20] Failed fetch Items. System = <SID> - P Queue = <printqueue> Print flag = False Archive flag = False ***** [ ReceiveItemsTask in RetrievalManager.cs at line 1628 ] *****
Environment
SAP Cloud Print Manager for Pull Integration 770
Cause
This issue occurs when there is more than one CPM software responding to the same print queue. With such scenario, the print queue does not know which CPM should be used.
Resolution
Only one CPM for print queue must be configured. As described in the SAP Help document attached:
"You should install the SAP Cloud Print Manager for Pull Integration once in your network. Thus, we recommend SAP Cloud Print Manager for Pull Integration to be installed on a central print server that is up and running all the time or at least during the time in which printing is needed."
See Also
SAP Note 2996934 - SAP Cloud Print Manager for Pull Integration 770
Keywords
CPM, PI, CPM for PI, Cloud Print Manager for Pull Integration, Print, Printing, Print Queue, Random, Fail, Red status, *** ERROR *** [20] Failed fetch Items, P Queue, Print flag = False Archive flag = False, ***** [ ReceiveItemsTask in RetrievalManager.cs at line 1628 ] *****, 770 , KBA , BC-CCM-PRN-OM-PQ , S/4HANA Output Management Print Queues , Problem
Product
Attachments
SapCloudPrintManagerHelp .pdf |