SAP Knowledge Base Article - Public

3226776 - Intermittent failure using CPM for Pull Integration

Symptom

You have configured Cloud Print Manager(CPM) for Pull Integration and the print queue are returning the status 'Failed' randomly for a print request. If you repeat the process, the print request might work without issues. In addition, the following error message can be seen in the CPM logs:
(xx.xx.xxxx xx:xx:xx) *** ERROR *** [20] Failed fetch Items. System = <SID> - P Queue = <printqueue> Print flag = False Archive flag = False     *****  [ ReceiveItemsTask in RetrievalManager.cs at line 1628 ]  *****

Environment

SAP Cloud Print Manager for Pull Integration 770

Cause

This issue occurs when there is more than one CPM software responding to the same print queue. With such scenario, the print queue does not know which CPM should be used.

Resolution

You must configure one CPM for print queue, as described in the SAP Help document attached:
"You should install the SAP Cloud Print Manager for Pull Integration once in your network. Thus, we recommend SAP Cloud Print Manager for Pull Integration to be installed on a central print server that is up and running all the time or at least during the time in which printing is needed."

See Also

2996934 - SAP Cloud Print Manager for Pull Integration 770

Keywords

print random, fail, red status, , KBA , BC-CCM-PRN-OM-PQ , S/4HANA Output Management Print Queues , Problem

Product

SAP S/4HANA Cloud 2202

Attachments

SapCloudPrintManagerHelp .pdf