SAP Knowledge Base Article - Public

3227146 - Candidate data is not showing in Integration Center for manually created Candidates in Recruiting

Symptom

Data of candidates that are manually created in Recruiting and added to Job Requisitions is not showing in an Integration Center job.

The problem is only happening with manually created candidates. Data of internal or external candidates, who apply on their own to the Job Requisitions, are available in Integration Center.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  • Steps to add a candidate:
  1. Recruiting
  2. Job Requisitions
  3. Click on Add Candidate in one Job Requisition from the Job Requisitions list
  4. Click on Add Candidate after being redirected to the Search for Candidates page
  5. Add a new candidate
  6. Save the candidate profile
  7. Click on Job Requisition at the top left
  8. See the candidate in Forwarded status in the Job Requisition applicants list
  9. Add the candidate to the Job Requisition

  • Steps to replicate the issue in Integration Center: 

        Prerequisite: the integration job uses fields from the jobApplication entity, the jobRequisition entity and the Candidate entity. 

  1. Run the integration in Integration Center
  2. Data from Candidate entity is empty (Candidate ID, First Name and Last Name)

Cause

The following setting is enabled in Manage Recruiting Settings: "Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement."

Resolution

As explained in the Recruiting Management guide: Configuring Candidate Search Based on DPCS Acceptance, when enabling the setting "Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement", candidates who have not accepted DPCS at least once will not be searchable in Candidate Search, nor in the Advanced Candidate Search, nor their data can be queried in Integration Center when querying the Candidate entity.

This setting does not have an impact on Reporting, nor on the Application UI, nor on the jobApplication entity in Integration Center. Data of the manually created candidates who have not accepted the DPCS at least once will show up in Reporting when reporting on fields from the Candidate table. These candidates can be seen in the Job Application Summary page. Data of these candidates can be queried in Integration Center when querying the jobApplication entity. 

There are two possible solutions for the issue:

  • Disable the setting "Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement"
  • Or build the integration with fields from the jobApplication entity

See Also

Configuring Candidate Search Based on DPCS Acceptance

KBA 2858457 - How to prevent candidates that have not accepted Data Privacy to display in any Candidate Search - Recruiting Management

Keywords

App, Uploaded, Manually, Created, Candidates, Added , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-RCM-API , Webservices & APIs , Problem

Product

SAP SuccessFactors Recruiting all versions