Symptom
You have created a Route Template to schedule visits only on working days but the Routes created based on it are not following the template accordingly.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Visits workcenter.
- Go to the Routes view.
- Click New -> type: Template.
- Edit the template as followed: no visits on weekends, select as many visits as you want.
- Save and open.
- Activate the template.
- Actions > Create Route from Template.
- The new Route is not following correctly the pattern for the visits, scheduling visits on unexpected days.
Cause
The system considers the calendar days for scheduling visits, regardless of the settings stablished in the Business Configuration (Calendar). Whenever a Visit day lands on a weekend, the system will automatically reschedule it for Monday, the first working day of the week.
Resolution
You'll have to manually change the visits. This is the current system behavior in the current release of SAP Cloud for Customer.
1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
2. If you are a customer:
Contact your Account Executive.
Check the link for SAP Advisory Services.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:
Keywords
Template Route, Scheduled Visits, Working Days, Weekends , KBA , LOD-CRM-ACT , Activities , Problem