SAP Knowledge Base Article - Public

3227630 - Confirmed Quantity on Service Order is Not Getting Updated

Symptom

The correct quantity should appear on the Service Order, but in you case all the items are with the confirmed quantity as 0.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Service Orders work center.
  2. Go to Service Order Processing View.
  3. Search for Service Order XYZ (XYZ is the ID of the Sales Order).
  4. Edit the Service Order and click on View all.
  5. Navigate to  Services and Spare Parts Tab.
  6. Select Item 10 which of type Service- Time and Material.
  7. You can under Delivery see the status Confirmed Quantity 0 Each.
  8. You expect it to be 1ea to be maintained since you have created the Service Confirmation with quantity 1 ea.

Cause

In Service Order XYZ, items 10 are non-billable.

Non-billable items are not counted towards the Confirmed Quantity in the Service Order, because the Confirmed Quantity is the value used for invoicing. Since the items are non-billable, the are not to be invoiced and so they are not added to the Confirmed Quantity.

Resolution

This is expected system behavior.

Keywords

Non-billable; Confirmed Quantity; Service Order , KBA , SRD-CRM-ORD , Orders & Contracts , How To

Product

SAP Business ByDesign all versions