Symptom
Start/Completion notification not received when scheduling Canvas via Report Center.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Go to Report Center
- Click on the three dots on the right side of the report you'd like to schedule
- Click on "New Schedule"
- On the schedule definition, select the two checkboxes for "Send Notification On"
- Finish the configuration and click on Submit
- Note that no e-mail notification will be received
Cause
No e-mail address maintained on BizX for the user that is scheduling the report.
Resolution
It is possible to check if the user has an e-mail configured on BizX creating a Table report on Employee Profile domain. If the E-mail column bring no values, this means that the user doesn't have an e-mail address configured.
To receive the Start/Completion notification when scheduling Canvas via Report Center, it'll be necessary to configure a valid e-mail address for the affected user.
Keywords
notification, canvas, report center, not received, e-mail , KBA , LOD-SF-ANA-ORD , Online Report Designer , Problem