Symptom
How to Generate to Create Rule Trace for Alerts & Notifications Jobs run in Provisioning
Rule trace log is blank when tracing Alerts and Notifications Jobs
Environment
Employee Central - Alert And Notifications
Reproducing the Issue
- Create rule trace to capture alert job log
- After job is completed in provisioning
- Download report
- Rule Trace report is blank
Cause
Configuration
- The Job owner not assigned in rule trace
- Rule does not trigger as expected
Resolution
To ensure the logs from a provisioning job is capture in rule trace:
- Ensure the rule is triggering correctly on its own
- Specify the job owner in the rule trace
For example: The alert job is created by someone in your company, that person must be added in the rule trace. Alternatively, to make this simple, if you have access to provisioning, you can delete the existing alert job and create a new one with yourself as job owner, then you can add yourself in the rule trace.
See Also
2257064 - Employee Central - Business Rule Execution Log
Keywords
Rule trace, rule log, alerts and notifications, provisioning jobs, blank rule log, , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem