SAP Knowledge Base Article - Public

3229486 - 'Skip Clause is not supported in CRM' error message appears when trying to build a query via Odata service in SAP Analytics Cloud (SAC)

Symptom

When building a query in SAP Analytics Cloud (SAC) via Odata Service from Microsoft Dynamics CRM 365 the following error message occurs:

  • "The following error message comes from the external data service: status: 400 body: {"error"¡{"code":0x0",message":" Skip Clause is not supported in CRM"}}"

Environment

  • SAP Analytics Cloud (Enterprise) 2021.8.17

Reproducing the Issue

  1. Create new dataset/model.
  2. From a data source.
  3. Odata Services.
  4. Select Connection.
  5. Build a Query.
  6. Select table.
  7. Select required objects.
  8. Click Create.
  9. Observe the error message.




    Cause

    • As KBA suggests: in order to bypass the limit for importing more than 1000 record per query, the server side paging ($skiptoken) has to be implemented.
      However, this $skiptoken is not supported when it comes to Microsoft Dynamics CRM 365. Which makes the workaround not doable. Therefore, the 1000 record per query limit can't be bypassed.

    Resolution

    According to the help page article for importing from OData services, the $skip parameter must be supported by the data service. The data service should be configured to allow pagination with $top and $skip parameters.

    See Also

    Your feedback is important to help us improve our knowledge base.

    Keywords

    odata, crm, Microsoft Dynamics CRM 365, Microsoft Dynamics SAC, Microsoft Dynamics odata, Odata 1000 limit, Odata limitation, odata 1000 record, Odata query, Microsoft Dynamics CRM 365 $skiptoken, skiptoken , KBA , LOD-ANA-AQU-ODATA , Acquiring Data into SAC using an ODATA connection , Problem

    Product

    SAP Analytics Cloud 1.0