Symptom
In the Agency Portal, as an Agency User, if you forward an existing Candidate Profile to a Job Requisition, the Phone Number added by the Agency User will not display, nor the existing Phone Number from the Candidate Profile will sync back to the Agency page.
NOTE: This only occurs when the existing Candidate Profile has been created through Career Site, Add Candidate, Referral, etc.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- In the Agency Portal, as an Agency User
- Submit a new Candidate Profile
- Make sure to enter an email already been used by another Candidate Profile
- Complete all other details, including the Phone Number
- System will inform the account already exists > Proceed with it
- Candidate Name will reflect the existing value
- Finish submitting it
- Phone Number will be empty
Cause
The Phone Number displaying in Agency Portal does not use the same database column as the Phone Number from the SuccessFactors side. When the Candidate account is created through the Agency and referred to SuccessFactors, the system pulls up the value from the Agency column and insert into the SuccessFactors one however, the same flow doesn't occur the other way around. When the Agency refers an existing Candidate account, the value present in the SuccessFactors column is not synched back to the Agency, hence the Phone Number field remains empty.
Resolution
This is currently considered as enhancement request.
Please provide this reference number to your CSM to get updates on this: RCM-111702.
Keywords
agency, phone, blank, missing, find, empty, null, candidate, RCM-111702 , KBA , LOD-SF-RCM-POR , Career and Agency Portals , Product Enhancement
Product
Attachments
Pasted image.png |
Pasted image.png |