Symptom
The call from ERP does reach the CPI tenant, although configurations and certificates are correct in ERP, so no iflows are triggered in the CPI tenant.
No record of the call in the CPI tenant http log.
ICM log: *** WARNING => Connect to *****-iflmap.hcisbp.us1.hana.ondemand.com:443 failed: NIECONN_REFUSED(-10)
SM59 error: SSL handshake with <CPI url> failed: SSSLERR_SERVERE_CERT_MISMATCH (-30)#Server certificate does not match supplied TargetHostname
Environment
- SAP Integration Suite
- SAP Cloud Integration
Reproducing the Issue
In SM59 of the ERP system, connect to the CPI tenant using RFC.
Cause
This issue most often stems from a lack of proper TLS SNI (Server Name Indication) presentation during the communication attempt performed.
Resolution
This can be addressed by ensuring that the parameter "icm/https/client_sni_enabled" is set to value "TRUE" at client-side, in the suit:
"icm/https/client_sni_enabled=TRUE"
Please refer to SAP Note 2124480 - "ICM / Web Dispatcher: TLS Extension Server Name Indication (SNI) as client "
See Also
SAP Note 2728600
Keywords
CPI, HCI, ERP, SNI , KBA , LOD-HCI-PI-RT , Integration Runtime , BC-MID-ICF , Internet Communication Framework , LOD-HCI-PI-CON-SOAP , SOAP Adapter , LOD-SF-INT-CPI-ERP , Standard SF to SAP ERP or S/4HANA Integration using CPI , Problem