Symptom
Custom cards are missing in homepage for all users after a successful instance refresh. All users have the necessary permissions to view the custom cards.
The custom cards were all copied and can be seen in Manage Homepage screen.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Login to customer's instance
- Go to Manage Home Page
- Click Organizational Links and there are 8 custom cards showing
- Go to homepage and no custom cards are showing
Cause
Root cause provided by engineering team is that the Instance Refresh process copied an incorrect custom card definition data from the source to the target.
The immutable company id is different between the source and the target, and it's being used in the key field for section data (default folder).
Hence the section data becomes incorrect in target instance, then the folder and its cards are not showing correctly.
Resolution
Fix was to update the section data changing the immutable company id part to the correct target id. Patch has been deployed last 27th of July.
See Also
2979181 - For You Today Engagement Cards & Quick Actions on The Latest Home Page
Keywords
no organizational updates, missing cards, issue after refresh, custom cards missing , KBA , LOD-SF-PLT-LHOM , Latest Home Page , Known Error