SAP Knowledge Base Article - Public

3231099 - User maintenance is generating an application error, when accessed by proxying a user

Symptom

Unable to access 'User maintenance'.

User receives Application error when any user proxies to other user who has permission to User maintenance and then try to access User maintenance from Admin-> User maintenance.

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Environment

  • SAP SuccessFactors HXM Suite
    • Analytics & Reporting (Ad Hoc, YouCalc, ORD)
      • Advanced Reporting (ODS)
      • Detailed Reporting - live data

Reproducing the Issue

  1. Login to instance
  2. Proxy to any user who has permission to access User maintenance
  3. Go to Reporting
  4. Select any canvas report and click on edit
  5. Go to Admin
  6. Click on User maintenance
  7. you will receive Application error 

Cause

Due to security constraint, accessing User maintenance with proxy user profile functionality has been changed.

Resolution

1. We can access User maintenance with direct login of user profile who has permission to access Admin-> User maintenance

2. Secondary login access given directly with the user having permission to User maintenance also works.

See Also

2151880 - Online Report Designer (ORD) Admin Features

Keywords

Application error, User maintenance, Admin, error, Application, canvas, Inconsistency , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors HXM Suite 2205