Symptom
Unable to access 'User maintenance'.
User receives Application error when any user proxies to other user who has permission to User maintenance and then try to access User maintenance from Admin-> User maintenance.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Analytics & Reporting (Ad Hoc, YouCalc, ORD)
- Advanced Reporting (ODS)
- Detailed Reporting - live data
- Analytics & Reporting (Ad Hoc, YouCalc, ORD)
Reproducing the Issue
- Login to instance
- Proxy to any user who has permission to access User maintenance
- Go to Reporting
- Select any canvas report and click on edit
- Go to Admin
- Click on User maintenance
- you will receive Application error
Cause
Due to security constraint, accessing User maintenance with proxy user profile functionality has been changed.
Resolution
1. We can access User maintenance with direct login of user profile who has permission to access Admin-> User maintenance
2. Secondary login access given directly with the user having permission to User maintenance also works.
See Also
Keywords
Application error, User maintenance, Admin, error, Application, canvas, Inconsistency , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-ANA-ORD , Online Report Designer , Problem