SAP Knowledge Base Article - Public

3231103 - Country Field in Address Info is editable in Hire UI despite configuring a rule

Symptom

  • You have configured an OnInit rule to set the country field to 'View" .
  • However, on the rule definition you don't see a CSF country field despite the field being configured.
  • The visibility set to the generic country field when used in the rule doesn't work and the field is displayed as editable.
  • Is there a way to select / mark this Country Specific "Country" field as "view" only?

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Employee Central

Cause

This is an Expected Behavior

Resolution

  • The system makes it editable by standard.
  • The field "Country" is a Business key for the country specific fields and cannot be set as "view"

Keywords

SF, EC, Success factors, Employee Central, Address Country , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , Problem

Product

SAP SuccessFactors HCM Core all versions ; SAP SuccessFactors HCM suite all versions