SAP Knowledge Base Article - Public

3231687 - Concur integration uses deprecated APIs, open a ticket under AP-INT-GEN

Symptom

You are replicating master data to SAP Concur and the application log of the Cost Object Outbound Run or Employee Replication Run is showing the following warning:

Concur integration uses deprecated APIs, open a ticket under AP-INT-GEN.

Environment

SAP Business ByDesign integration to SAP Concur Expense

Reproducing the Issue

1. Go to Master Data Replication – Cost Object Outbound Runs

2. Select Start Immediately and wait until the processing status is set to Finished

3. Click the Application Log ID link

4. Go to Results and expand Establish Connection with Target System

5. Warning: Concur integration uses deprecated APIs, open a ticket under AP-INT-GEN

The same message occurs when you trigger an Employee Outbound Run.

Cause

With the upgrade to 22.05, a silent data migration was delivered to automatically adapt the integration with SAP Concur Solutions to the new JSON Web Token based authentication mechanism. Also, the deprecated v1 Financial API was to be replaced by the Financial Integration Service v4. This migration was done automatically and did not require any manual configuration changes.

This automatic migration did not succeed in your tenant. The integration to SAP Concur is still using the deprecated APIs. This communication method will no longer be supported after the release upgrade to 22.11 and the replication runs will fail.

Resolution

Please open a customer incident under component AP-IN-GEN.

Keywords

SAP Business ByDesign and Concur Integration, Cost Object Outbound Runs, Employee Outbound Runs, deprecated APIs , KBA , AP-INT-GEN , Reuse parts of the DU Integration Orchestration , Problem

Product

SAP Business ByDesign all versions