Symptom
- An error is being received when trying to access the field mapping tool.
- Unable to load the fields in field mapping tool.
- Cannot access the field mapping tool and intermittently receiving errors.
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Login at the instance
- Search for the Field Mapping Tool for onboarding and employee central
- Wait for the page to load and an application error is being received.
Cause
- The issue is due to too many concurrent calls from the mapping page.
- The number of calls multiply when the number of mappings increase.
- There is no recent change in the product which caused this.
- Newer version of browsers has restrictions in the total number of concurrent ajax calls.
Resolution
Solution/Workaround :
- Reduce the number of mappings on the page. Remove unwanted field mappings. Once this is done, the page will load fine.
- Use the XML-based mapping on the provisioning page.
Permanent fix :
- This needs major design change including introducing pagination for the page.
- The Engineering Team has filed an enhancement ticket ONB-32879.
Since we do not process enhancement monitoring via support ticket, the enhancement internal ticket ONB-32879 can be posted via SAP Influence Portal. You may seek assistance from your CSM/Account Manager on how this ticket can be posted there for monitoring purposes.
Keywords
ONB-32879, Field Mapping Tool, Application error, ONB-33014, ONB-EC mapping, Onboarding 1.0, OBD, ONB1.0, Onboarding , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , Product Enhancement
Product
SAP SuccessFactors Onboarding 2205