SAP Knowledge Base Article - Public

3232628 - Hours are not back in app Manage Project Billing after billing cancellation

Symptom

After the cancellation of the Billing Document - Invoice and rejection of project BDR - Billing Document Request, the hours are not back in Manage Project Billing.

Environment

SAP S/4HANA Cloud CE2202& CE2208

Reproducing the Issue

  1. In app Manage Project Billing, create the BDR.
  2. Create Invoice based on the BDR.
  3. Cancel the Invoice.
  4. Reject the BDR.
  5. The hours are not back in app Manage Project Billing.

Cause

When an Invoice which is created for a BDR is cancelled, there could be cases wherein the Journal entries for the Invoice Cancellation is not posted.
Meanwhile if the BDR corresponding to the invoice is Rejected, or Deleted, and after this, if the Invoice Cancellation Journal Entry is posted, then still the postings will not be considered for new Project Billing cycle, as the status of the BDR in MPB is still "Billing Requested".
That's because the BDR cancellation was not successful from Project Billing perspective as the Invoice Cancellation was not yet posted.

Resolution

SAP development team is working on stopping BDR Reject and BDR Delete if its corresponding Invoice’s cancellation Journal entries are not posted.
The fix is planned for CE2302 release.

This is the current planning and may be slightly changed by SAP at any time without notice.

Workaround before the correction:
Follow the correct sequence of steps during the cancellation process.
Make sure to reject or delete DBR after the Journal entries for the Invoice Cancellation are posted.

Keywords

Manage Project Billing, hours missing, invoice cancellation, BDR reject, BDR delete , KBA , PS-BIL , Project Billing , SD-BIL , Billing , Problem

Product

SAP S/4HANA Cloud 2202 ; SAP S/4HANA Cloud 2208