Symptom
Integration Center creates empty outbound file at SFTP with selected fields even when there is no data present to fetch / data is null.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Integrations
- Integration Center
- Integrations
Reproducing the Issue
1. Login to SF instance
2. Search "Integration Center"
3. Create a Outbound Job which has null data and configure SFTP Destination Settings
4. Run the Job
5. You'll see file with selected columns, null data in SFTP.
Cause
This was standard behavior of Integration Center till 1H 2022.
Resolution
New feature added in 1H 2022 release.
You can now select the Exclude empty files option to stop generating empty files for file-based outbound integrations. For REST or SOAP integrations, you can select the Exclude empty requests option to stop generating empty requests.
Procedure:
1. Open your integration Job
2. Go to Destination settings -> Advanced Settings -> Check the box "Exclude empty files"
3. You will no longer see empty file at destination.
Here's a screenshot of the Exclude empty files option for file-based integrations.
Here's a screenshot of the Exclude empty requests option for REST integrations.
See Also
Keywords
Empty File, Null data, SFTP, Integration Center, SF, SFTP. , KBA , LOD-SF-INT-INC , Integration Center , How To