Symptom
When purging feedback/trend information from Employee Profile, even though the status is as PURGED, the rating information is still appearing on the profile.
Environment
SAP SuccessFactors Employee Profile
Cause
Feedback purge on EP side only supports purge the feedback data whose module is LiveProfile self service(Type 2)
Data from module LiveProfile import(Type 4) is not supported to purge
LiveProfile self service(Type 2) refers to the records added through Employee Profile Page
LiveProfile Import(Type4) refers to the records added through Live Profile Import Job
Resolution
To check the source of the data you can go to:
- Export Extended User Information
- Set 'Trend Information'
- Choose to include active user only or inactive also
- Click on 'Export Extended Data only'
- Open the file and check 'source' and 'module' of the user affected
Reference: 2149125 - Identifying the Source of Ratings in the Trend Portlets
Currently is how the system is designed, trend data from LiveProfile import will not be purged.
To be considered in the upcoming releases kindly raise an enhancement request.
To submit an enhancement request please refer to 2090228 - How to Submit Ideas for SAP SuccessFactors Products.
See Also
Data Included in the DRTM Employee Profile Purge | SAP Help Portal
2091409 - Import & Export Process for Extended User Information in SuccessFactors HXM Suite
2587024 - Trend Information import not overwriting previous values for inactive users
Keywords
DRTM, trend data, feedback, purged, not purged, LiveProfile, LiveProfile Import, trend information, trend, export extended user information , KBA , LOD-SF-EP-PORT , DO NOT USE [Replaced by LOD-SF-PM-POD] , Product Enhancement