SAP Knowledge Base Article - Public

3234195 - Payment terms are reset when changes are made to the account address in a contract.

Symptom

After the adaption of an account address in a contract, the payment terms are reverted.

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. Open the work centre Sales Orders > Contracts
  2. Search for the relevant contract
  3. Click Edit/ View All
  4. Navigate to the Pricing and Invoicing tab and the Invoicing sub-tab
  5. Change the Payment Terms field to a different value and click Save
  6. Navigate to the Involved Parties tab and change the address of the account (e.g. the house number)
  7. Click Save
  8. Navigate to the Pricing and Invoicing tab and the Invoicing sub-tab
  9. You can see that the payment terms have been reset to what they were previously.

Cause

When a change is performed on a party, such as the address, the system triggers some modifications to be run, one of which is a redetermine of the buyer details. As the payment terms in the master data differ from that in the document, it will be set to the master data details linked to the sales arrangement.

Resolution

This is the expected system behaviour.

Keywords

Change address, involved parties, automatically, edited, , KBA , AP-CCP , Customer Contract Processing , Problem

Product

SAP Business ByDesign all versions