Symptom
Whenever you are navigating and processing documents such as Sales Orders for example, you face the following errors:
No result returned by external provider
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Search for ID ABC (ABC represents the ID of the Sales Order).
- Click Edit.
- Click View All.
- Errors:
No result returned by external provider.
Cause
The communication arrangement being used in the Vertex integration has the path missing and thus the URL is not completed.
- Go to the Application and User Management work center.
- Select the Communication Arrangements view.
- Select the Vertex communication scenario.
- Click Check Completeness.
- Error: URL for outbound communication missing.
- Click Edit.
- Navigate to the Technical Data tab.
- Click the Edit Advanced Settings button.
- Under Outbound and Outbound Communications.
Path is empty.
Resolution
This is the system expected behavior.
To correct this, please maintain a path in the communication arrangement.
- Go to the Application and User Management work center.
- Select the Communication Arrangements view.
- Select Request tax rates from Vertex.
- Click Edit.
- Navigate to the Technical Data tab.
- Click the Edit Advanced Settings button.
- Under Outbound and Outbound Communications.
- Add the path vertex-ws/services/CalculateTax60.
- Click Save and Reactivate.
See Also
2257888 - No Result Returned by External Provider VERTEX
2986871 - Vertex Error: SOAP:1,044 SRT: Consumer is temporarily isolated.No processing is allowed
Vertex Configuration in SAP Business ByDesign
Keywords
Vertex, Error, URL, Outbound, Outbound Communication, Missing, issue, Path, Sales, Document , KBA , AP-TTE-TC , Tax Calculation , How To