SAP Knowledge Base Article - Public

3234355 - URL for Outbound Communication Missing

Symptom

Whenever you are navigating and processing documents such as Sales Orders for example, you face the following errors:

No result returned by external provider

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Search for ID ABC (ABC represents the ID of the Sales Order).
  4. Click Edit.
  5. Click View All.
  6. Errors:

No result returned by external provider.

Cause

The communication arrangement being used in the Vertex integration has the path missing and thus the URL is not completed.

  1. Go to the Application and User Management work center.
  2. Select the Communication Arrangements view.
  3. Select the Vertex communication scenario.
  4. Click Check Completeness.
  5. Error: URL for outbound communication missing.
  6. Click Edit.
  7. Navigate to the Technical Data tab.
  8. Click the Edit Advanced Settings button.
  9. Under Outbound and Outbound Communications.

Path is empty.

Resolution

This is the system expected behavior.

To correct this, please maintain a path in the communication arrangement.

  1. Go to the Application and User Management work center.
  2. Select the Communication Arrangements view.
  3. Select Request tax rates from Vertex.
  4. Click Edit.
  5. Navigate to the Technical Data tab.
  6. Click the Edit Advanced Settings button.
  7. Under Outbound and Outbound Communications.
  8. Add the path vertex-ws/services/CalculateTax60.
  9. Click Save and Reactivate.

See Also

2257888 - No Result Returned by External Provider VERTEX
2986871 - Vertex Error: SOAP:1,044 SRT: Consumer is temporarily isolated.No processing is allowed
Vertex Configuration in SAP Business ByDesign

Keywords

Vertex, Error, URL, Outbound, Outbound Communication, Missing, issue, Path, Sales, Document , KBA , AP-TTE-TC , Tax Calculation , How To

Product

SAP Business ByDesign all versions