SAP Knowledge Base Article - Preview

3234594 - SAP Commerce Cloud: same build fails when using older release and useCloudExtensionPack in the manifest

Symptom

You are using useCloudExtensionPack in your manifest.json, as described in Help Portal - Manifest Components Reference, and the build fails with the following:

INFO d.h.c.c.t.EvaluateCoreCommerceArtifactsTask [main] Validating usage of Commerce Suite version 1811.xx
INFO d.h.c.c.v.s.SupportedCSVersions [main] Validating version 1811.xx
INFO d.h.c.c.v.s.SupportedCSVersions [main] Commerce Suite version <versionLine=1811, patch=xx, qualifier=null> is supported
INFO d.h.c.c.ExactCommerceSuiteVersionUtil [main] Determined Commerce Suite version from artifact: 1811.xx
Exception in thread "main" de.hybris.ccv2.corecommerce.manifest.CommerceManifestValidationException: useCloudExtensionPack configured in the manifest is not supported with declared commerce version
 at de.hybris.ccv2.corecommerce.task.EvaluateCoreCommerceArtifactsTask.process(EvaluateCoreCommerceArtifactsTask.java:67)
 at de.hybris.ccv2.Builder.runTask(Builder.java:256)
 at de.hybris.ccv2.Builder.lambda$runTasks$5(Builder.java:223)
 at java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1655)
 at java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:658)
 at de.hybris.ccv2.Builder.runTasks(Builder.java:218)
 at de.hybris.ccv2.Builder.run(Builder.java:100)
 at de.hybris.ccv2.Builder.main(Builder.java:56)


Read more...

Environment

SAP Commerce Cloud in the Public Cloud, release 1811

Product

SAP Commerce Cloud 1811

Keywords

KBA , CEC-HCS-CCAZ-BUILD , Environment builds , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.