Symptom
When trying to search for a candidate based on a value from their Profile Extension, the search returns 0 results.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Fill out Data Capture Form
- Fill in a field that is associated to candidate profile extension and click Submit
- Log in to instance as recruiter
- Recruiting>Candidates
- Go to "Profile Extension" drop-down on search criteria
- Choose the field that was filled in on Data Capture Form, enter the value and click Search
- See that the Search returns no results
- Go to Admin Center>Manage Data>Candidate Profile Extension and re-update the field there
- Follow steps 4-6 and you will see that the search will now return the result after re-updating in Manage Data
Cause
If the setting "Ask external candidates to set their visibility settings when creating an account or profile" in Provisioning>Edit Candidate Privacy Options has been enabled before in the past, the system expects you to enable "Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement" in Manage Recruiting Settings for this search to work, as it honours DPCS once it is enabled.
If the option was never enabled, it works without enabling "Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement".
Resolution
If the setting "Ask external candidates to set their visibility settings when creating an account or profile" in Provisioning>Edit Candidate Privacy Options has been enabled before in the past, please enable "Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement" in Manage Recruiting Settings in order for the search to work correctly.
Keywords
candidate profile extension, not searchable, no results, zero results, cannot, found , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , How To