Symptom
Error message while User Mapping from CPQ to SFDC
Resolution
Symptoms
Getting the error message while trying to map CPQ user "Tania Wisel" to CRM user
Error message "It is not possible to map CPQ user with CRM user because selected CRM user is already mapped with another CPQ user"
Diagnosis
CPQ user Abhinav Singhal is mapped to CRM user"Tania Wisel". In CPQ you can not see it that way. This is because the moment Abhinav Singhal is mapped in CPQ that user in SF is called Singhal Abhinav.
CPQ remembers the ID and the user's name the instant that mapping was done. The user in SF, Singhal Abhinav, was renamed to Tania Wisel, which is the root cause of the problem.
Solution
If we delete mapping in CPQ for CPQ user Abhinav Singhal then we will be able to map Tania Wisel.
We should know how they have createed their CRM users. If they have renamed a particular SF user, they should first delete the mappings in the CPQ for that user.
Here we should know that they have renamed Singhal Abhinav to Tania Wisel. If we don't know, and try to map the SF user to the CPQ user we will not succeed in doing so unless we delete the original CPQ mapping for that user who has the name of the original mapping.
Keywords
KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To
Product
SAP CPQ all versions