Symptom
- CPQ Reports option is not visible in the Main Menu dropdown when accessing a CPQ quote from C4C.
- It's possible to access CPQ Reports by clicking on Setup option (if the SSO user is an Admin User in CPQ) in the Main Menu from the C4C screen.
- It's also possible to access Reports option from Main Menu when logged into CPQ directly as a standalone application.
Environment
- SAP C4C
- SAP CPQ
Reproducing the Issue
- Login to C4C
- Open a Sales Quote (CPQ quote)
- Click on the gear icon on the top-right corner
- Reports Option is not there
Cause
-
This is expected behaviour.
-
When a User lands from C4C, they will have limited options in CPQ.
-
And Report module not being offered as an option in User Menu is one of them.
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This is because User should only deal with quote related objects when landing from C4C to CPQ.
Resolution
- If the SSO User has Administrator privileges in CPQ, then they can click on the Setup Option in the Main Menu dropdown of C4C and access Report Module from Setup -> General -> Report Module.
- Alternate way would be to login to CPQ directly as a standalone application and then access Reports from the Main Menu dropdown in CPQ, and also from under Setup -> General -> Report Module.
- The same is documented as a limitation in the help documentation: https://help.sap.com/docs/SAP_CPQ/f80fbcd4f1c74232839c30ce26886f07/0e9b1edc99ed4c07969b760d5e0dadb5.html?version=2105
- It says here "Users landing from SAP Cloud for Customer can access a set of SAP CPQ features that are limited to working with quote-related objects: they can access the User Page and Quote Layout pages under the Setup icon, but features such as Reports are not available."
Keywords
unable to access Reports from C4C, Reports option missing, CPQ, C4C, main menu, dropdown, user menu, cpq sales quote, c4c opportunity , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ 2020