SAP Knowledge Base Article - Public

3235080 - No Contact Person Name in XML Data of Customer Invoice

Symptom

Contact is selected in the sales order but when the Customer Invoice form is created, it is not available to be mapped in the form. You find that no contact person name in XML data of the customer invocie.

Environment

SAP Business ByDesign

Reproducing the Issue

1. Go to the Customer Invoicing Work Center

2. Select the Invoice Document View

3. Search for the Customer Invoice ABC (where ABC represents the invoice ID)

4. Click on Edit and View All

5. Navigate to Output History view

6. Click on the View Data XML button

No contact person name in XML data

Cause

The BillToParty-ContactPerson field is present for countries GB/FR/CA/AU/ZA/DK/SG/NO and for all these countries the contact person is determined from the bill to party contact details and will fill the contact person details for the above mentioned countries in the XML (If maintained in master data).

The example Customer Invoice ABC is for country AE, which is why there is no contact person name in XML data .

Resolution

This is the current system behavior.

In this case, we recommend you to have an extension field with this information and then using that field for the desired purpose.

Note that Header Level Extension Fields will be considered a Split Criteria, find more information on KBA 1500875 - Split Criteria in Customer Invoicing.

Keywords

Contact Person, Customer Invoice, BillToParty, output, form template , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign 1905 ; SAP Business ByDesign 1908 ; SAP Business ByDesign 1911 ; SAP Business ByDesign 2002 ; SAP Business ByDesign 2005 ; SAP Business ByDesign 2008 ; SAP Business ByDesign 2011 ; SAP Business ByDesign 2022 ; SAP Business ByDesign 2102 ; SAP Business ByDesign 2105 ; SAP Business ByDesign 2108 ; SAP Business ByDesign 2205 ; SAP Business ByDesign 2208 ; SAP Business ByDesign 2211