Symptom
A sales document contains a sold-to party, but the system still shows the field in the incompletion log:
Missing Data: Sold-to party.
Message no. VU019
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the Create Sales Orders - VA01 app
- Enter the order type
- Enter the sold-to party
- Click Save
- Error Missing Data: Sold-to party is displayed in the incompletion log
Cause
The respective sold-to party has the field Default SP selected in the Maintain Business Partner app.
Resolution
1. Go to the Maintain Business Partner app
2. Enter the respective business partner
3. Select Customer at Change in BP role:
4. Go to Customer: General Data tab
5. Go to Customer Types section and deselect the field Default SP:
Keywords
Missing Data: Sold-to-party, VU019, Message no. VU019, Incompletion log, empty, sold to party, Sold-to-party, Missing Data, sales document, credit memo, sold to, incompleteness, sales order , KBA , SD-SLS-GF-IL-2CL , Incompletion log (Public Cloud) , SD-SLS-SO , Sales Orders , How To
Product
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SAP Knowledge Base Article - Public