SAP Knowledge Base Article - Public

3236009 - Cannot create an SAC user after deleted an user with the same email id before

Symptom

  • Cannot create an SAC user after deleted an user with the same email id before.
  • This issue is only happens for this specific email.
  • The following error is shown when tried to add a new user with this email:

dberror(PreparedStatement.executeUpdate): 4240 - Duplicate identity for this provider: line 1 col 34 (at pos 33)
Correlation ID: 39736092-5612-4552-a593-124990047829

Environment

  • SAP Analytics Cloud (Enterprise) 2022.8.17 

Reproducing the Issue

  1. Logon SAC.
  2. Try to add a new user with email which was deleted before.
  3. Failed to add this user with the below error:

dberror(PreparedStatement.executeUpdate): 4240 - Duplicate identity for this provider: line 1 col 34 (at pos 33)
Correlation ID: 39736092-5612-4552-a593-124990047829

Cause

The issue is under investigation by developer group.

Resolution

The issue is under investigation by developer group.

Keywords

remove delete add create user email address , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0