SAP Knowledge Base Article - Public

3236783 - Wrong Sort Order in the OutboundDeliveryExecutionRequest Items

Symptom

In a 3PL scenario OutboundDeliveryExecutionRequest Document ID KLM has the items in wrong order it starts at the highest Line item ID  and ends with the smallest line item ID.(KLM refers to 3PL Request ID).

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to Third-Party Logistics Work Center
  2. Go to 3PL Requests View
  3. Search for KLM and Select Edit
  4. Go to Document Flow
  5. Open Outgoing Outbound Delivery Execution Request KLM
  6. View all
  7. Show Payload

You can find the line items are in descending order.

Cause

In relation to the payload sent by the B2B outbound process agent to the 3PL provider, there is currently no exit in the B2B outbound agent to control the data being populated or the sequence in which it gets populated.

Resolution

 This is the current designed behaviour of the system.

Keywords

Wrong Sort order, OutboundDeliveryExecutionRequest, Item, web service, 3PL, Document ID, items,wrong order, it starts at the highest Line item ID and ends with the smallest line item ID , KBA , outbounddeliveryexecutionrequest , line items are in descending order , 3pl scenario outbounddeliveryexecutionre , AP-ODP-ODR , Outbound Delivery Request , Problem

Product

SAP Business ByDesign all versions