SAP Knowledge Base Article - Public

3237466 - Database size in the tenant has reached it's limit or crossed the limit

Symptom

The tenant's DB size was almost reaching the limit.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

1. Login to CPQ tenant

2. Go to Setup

3. On the Setup Home dashboard, Database size shows up.

4. The Database size has either almost reached the limit or crossed the limit.

Cause

  1. Upon checking with the internal Ops team, the log file in tenant DB needed to be shrunk.
  2. The table with the most DB size happened to be UserActionAuditTrail table.

Resolution

  • Internal Ops team shrunk the Log file size  upto 10GB.
  • Customer has also been pointed out to the table having the most DB size in their tenant which is the UserActionAuditTrail table.
  • This table can easily be cleaned by customer by setting up Audit Trail Deletion in their tenant so that older data can be deleted automatically from UserActionAuditTrail table in the future.

See Also

https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/2ada92a23a9c4e72932a412c52587fb3.html?q=audit%20trail%20delete

Keywords

db size, reach the db limit, cross the db limit, db shrink, shrunk, audit trail deletion, Data Deletion, User Action Audit Trail , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions