SAP Knowledge Base Article - Public

3238510 - Business partner api affecting credit profile creation via api

Symptom

Error message number: "UKM_BP135" Business partner YYYYYYY does not participate in Credit Management.

Environment

SAP S/4HANA Cloud.

Reproducing the Issue

Use the API API_CRDTMBUSINESSPARTNER https://api.sap.com/api/API_CRDTMBUSINESSPARTNER/overview to PATCH the Credit Profile of business partner.

Cause

Credit management role assignment is pre-required for the API API_CRDTMBUSINESSPARTNER.

Resolution

Add the Credit management role using a job-template "Assign Credit Management Role to Business Partners"

https://help.sap.com/docs/SAP_S4HANA_CLOUD/918bca53037f408f91a2295d04ac16bc/0b036b19bb1c4e8693b5bdc014ed591c.html?locale=en-US 

Afterwards use the API API_CRDTMBUSINESSPARTNER for patching the Credit Profile and Credit Segements.

Refer the patch operation in help.sap.com document https://help.sap.com/docs/SAP_S4HANA_CLOUD/ce8c2b9687e94c2eb70ab34e92e6fba5/82fb5abf2c5f4a919ee3060df8b2692f.html?locale=en-US 

 

Keywords

API, API_CRDTMBUSINESSPARTNER, S4_PC, UKM_BP135, Business, partner, YYYYYYY, does, not, participate, in, Credit, Management, , KBA , FIN-FSCM-CR , Credit Management , FIN-FSCM-CR-2CL , Credit Management (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions