Symptom
- In Employee profile for all the portlets fields related to type picklist, admins are able to see all values in dropdown, effected users are not able to see any values in the picklist type field's dropdown. When admin tries to proxy as the effected user, they are able to see all values in dropdown.
- Not all picklist values shows up in relationship type field of Emergency Contact when end-user tries. All values shows up if admin tries the same.
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors HXM Suite Core 2205
Reproducing the Issue
- Proxy as effected user and try to view picklist type fields.
- Observe that no values appear in the dropdown and the picklist keeps trying to load.
- Find the picklist id associated with the field from Manage Business Configuration tool.
- Check picklist id in picklist center for translations maintained for the values.
Cause
- Subject User's default locale is en_UK in the Employee Export File.
- Using basic import wrong default locale en_UK was uploaded for employees.
Resolution
The root cause is:
- Subject User's default locale is en_UK, which is incorrect code.
- In Employee Export file Incorrect code = en_UK is updated for affected users, in the default locale column.
- As per below Knowledge Base Article supported correct code is en_GB.
2269945 - List of Supported Languages with Locales for SuccessFactors
Solution:
- Update default locale of all the affected users from en_UK to en_GB using basic import.
- Temporary quick solution for subject user to switch language from profile personal menu on top-right corner > Settings >Change Language > to en_US or reselect English_UK (en_GB).
Keywords
Unable to access picklist values by some users, en_GB, en_UK, correct English UK code, picklist dropdown not showing any values, picklist dropdown not loading , KBA , LOD-SF-EC-ADM , Admin Tools (EC Core only) , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Suite Core 2205