SAP Knowledge Base Article - Public

3238674 - Contact Column Empty In Target Group

Symptom

No contacts are in the Contacts column for a Target Group (TG) where you successfully determined accounts.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales Campaigns work centre
  2. Go to the Target Groups view
  3. Create a Dynamic Target Group 
  4. Under the 'Member Determination' facet, add 'Conditions for Accounts'
  5. Save and enter the schedule as per your requirement
  6. Actions -> Activate
  7. Go to the Members facet, however, give the system a moment for the member determination to run (this can vary depending on the amount of results found)

Result: once members are determined you see that the 'Contacts' column is empty, despite several accounts having contactable contacts maintained (valid e-mail address, contact permission = allowed, etc.).

Cause

For Contacts to be displayed in the Contacts column of a Target Group, you need to actively determine contacts in the Target Group, too.

Resolution

  1. Repeat steps 1. - 3. from above
  2. Also add conditions for the section 'Conditions for Account Contacts' 
  3. Repeat steps 5. - 7.
  4. Once members are determined, if the conditions that were set match data in the system and the contacts have contact permission = allowed/ e-mail addresses maintained, etc., contacts will now show up in the Contacts column of the Members facet in the Target Group, too. 

Keywords

TG, Target Group, contact, missing, empty, Campaign , KBA , LOD-CRM-MKT-TG , Target Groups , How To

Product

SAP Cloud for Customer core applications 2205