Symptom
No contacts are in the Contacts column for a Target Group (TG) where you successfully determined accounts.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales Campaigns work centre
- Go to the Target Groups view
- Create a Dynamic Target Group
- Under the 'Member Determination' facet, add 'Conditions for Accounts'
- Save and enter the schedule as per your requirement
- Actions -> Activate
- Go to the Members facet, however, give the system a moment for the member determination to run (this can vary depending on the amount of results found)
Result: once members are determined you see that the 'Contacts' column is empty, despite several accounts having contactable contacts maintained (valid e-mail address, contact permission = allowed, etc.).
Cause
For Contacts to be displayed in the Contacts column of a Target Group, you need to actively determine contacts in the Target Group, too.
Resolution
- Repeat steps 1. - 3. from above
- Also add conditions for the section 'Conditions for Account Contacts'
- Repeat steps 5. - 7.
- Once members are determined, if the conditions that were set match data in the system and the contacts have contact permission = allowed/ e-mail addresses maintained, etc., contacts will now show up in the Contacts column of the Members facet in the Target Group, too.
Keywords
TG, Target Group, contact, missing, empty, Campaign , KBA , LOD-CRM-MKT-TG , Target Groups , How To
Product
SAP Cloud for Customer core applications 2205