Symptom
- 'Failed to send data. Please try again later' error when adding an attachment on mobile application within benefit claims.
Environment
- SAP SuccessFactors Mobile
- SAP SuccessFactors Employee Central
- SAP SuccessFactors Global Benefits
Reproducing the Issue
1. Go to the benefit section for an employee in the mobile application.
2. Make a claim for one of the benefits
3. You receive an error 'Failed to send data. Please try again later' error when adding an attachment on mobile application within benefit claims.
Cause
Attachment field in mobile is removed recently due to a security reason.
Resolution
We are working on that fix, however there is currently no definitive timeline yet.
Workaround: Go to the Benefit Claim object and set attachment Mandatory = 'No'
For web, you can set the field as mandatory through Manage UI Configuration.
See Also
Keywords
mobile, claim, benefit, 'Failed to send data. Please try again later', attachment, mandatory, SF Mobile, , KBA , LOD-SF-EC-GBF , Global Benefits , Problem