Symptom
When adding a new employee the message "Please set one record as primary record for Email Information" appears, even without a rule triggering it:
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Add New Employee;
- Fill in the employee data and set no email as primary;
- Submit;
- Error will pop up.
Cause
The error message is related to a hard-coded validation triggered for email information, that requires at least one Email set as "Yes" or the "Is Primary" field. You can set either email type Personal/Business as primary, but at least one have to be the primary one.
Resolution
Set one email as primary.
See Also
More information about email configuration can be found in the guide:
Email Information [Employee Central hris-element-id: emailInfo]
Keywords
email, primary, employee, error, save, Please set one record as primary record for Email Information , KBA , LOD-SF-EC-HIR-NEW , Add New Employee Wizard , How To