Symptom
- DHS Suddenly Identify a Duplicate Case for the said Candidate.
- In some cases, there shouldn't be a Duplicated E-Verify Case for the affected Candidate/s.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as the Assigned User for the E-Verify Case of the Candidate
- Click Complete E-Verify
- Click Start on the Complete E-Verify: Case Status is "Create and Submit"
- Click Submit
- The Department of Homeland Security identified a duplicate case entry for x-candidate. Please close the duplicate cases created for x-candidate, or go to Manage Data and provide a reason for creating a duplicate case for this new hire.
Cause
There are two steps when we create ev case:
- Create -> the case number is assigned and returned to us
- Submit -> the case is submitted to DHS
If (1) fails, Bizx doesn't have case number and we should see e-verify case on DHS side in DRAFT status. In this case we could just close duplicate.
If (2) fails, Bizx should receive caseNumber from (1) response. But the case might be in some new status on DHS side.
Resolution
It happens from time to time, because DHS has some issues and when we send data to them, they create the case, but they fail to respond us back. As a result Bizx doesn't have case number, but DHS has case number created. So the only option is to close this case as duplicate
Keywords
E-Verify, Duplicate Cases , KBA , LOD-SF-OBX-EVF , Everify , Problem