SAP Knowledge Base Article - Public

3240016 - SAC Managing Users and Teams API does not apply changes with PUT method

Symptom

You would like to update a users created via SAC Users and Teams API using PUT method.

After filling the user schema accordingly to /Users | SAP Help Portal, the changes are not applied. For example, the "familyName" attribute is still the same

Environment

SAP Analytics Cloud 2022.8.17

Reproducing the Issue

1. Try to edit a user created via SAC Users and Teams API using the PUT method. Update one of the fields: givenName, familyName or displayName

2. Fill the user schema accordingly to /Users | SAP Help Portal

3. Changes were not applied

Cause

There are some properties used only at user creation, then unchangeable.

  • userName and id cannot be changed once the user has been created
  • givenName, familyName and displayName can only be updated by the identity provider

Resolution

This works as designed as the API will not update any attributes in the user object that are mapped SAML attributes

From the API documentation here there is a note stating:

If you are using SAML authentication, and you are using USER ID as your SAML mapping, you cannot change the userName using this API. The userName you use in the request body must match the user <ID>

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP API, PUT, userName, id, User and Team, SICM, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , LOD-ANA-ADM , SAC Administration , How To

Product

SAP Analytics Cloud 1.0