Symptom
Since suppression of identical records cannot be deactivated from SL framework side for the following comp-specific use case, we shall test a possible workaround for customers.
Use case:
Multiple records per day, where there are changes to the Recurring Pay Component Records, but the Compensation Information Records are identical.
When updating the Recurring Pay Component data via Import or API, in this case suppression of identical records with Centralized Services does not update change on Recurring Pay Components.
When updating Recurring Pay Component and after Compensation Information with Sequence Number 1 (updating existing record) you receive the error "This record was not saved because there were no new changes compared to the existing record. "
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
Via Full Purge or Incremental Import or API
Scenario:
You wish to create 3 Compensation records for a user on the same day. To achieve this there are three Compensation Information records with the same Event Reason each with a different sequence number. There are three Pay Component Recurring records with a change to a pay component amount in each record. (There are changes to the Recurring Pay Component Records, but the Compensation Information Records are identical.)
- Import or upsert the three Compensation Information records with Centralized Services.
- The system evaluates the record and sees no data changes.
- Suppression of identical records is triggered and only the first record is created.
- Attempt to import the three Recurring Pay Component Records
- An error occurs as there is not corresponding Compensation Information Record for sequence number 2 and 3
Scenario:
You wish to update Pay Component Recurring and the existing Compensation recordsfor a user, keeping Sequence Number as 1 for this record.
- Import Pay Component Recurring and Compensation Information records (Suppression of identical records is universally triggered)
- Compensation Information import should upload only USER ID, start date, Event Reason (Same as pay component Import or different) file, Reason for change and Sequence Number (One).
- An error occurs "This record was not saved because there were no new changes compared to the existing record. "
Cause
This is caused by Suppression of Identical Record logic in Centralized Services universally enabled.
Resolution
A future comprehensive standard solution is planned which will prevent this issue. This currently has no confirmed release date.
Below are some listed workarounds to prevent this issue from occurring.
- Instead of having three records make all required changes in one Compensation Information record and on Pay Component Recurring record.
- Use a different Event Reason for each Compensation Information Record if possible.
- Import a dummy value for example a different text value to the notes field for each record such "import 2" and "import 3".
- Maintain a custom field with auto generation in such cases.
Workaround instructions:
- Create a new custom-long field on the Compensation Information and enable the field
- Check that the admin user has no permission to see the field (it is not visible on the UI)
- Create an onSave rule to set the field value to the sequence number
See Also
Keywords
Unable to find a CompInfo record matching the time slice of this PayComponentRecurring record. Review the data and try again, ECT-200710, ECT-190481, Unable to find a CompInfo record matching the time slice of this PayComponentRecurring record, compInfo, pcr, paycomponentrecurring, pay component recurring, compensation, compensation information, supress, identical, supress update, identical records, api, import, upsert, INC1745769, integration, Centralized Services, CS, update comp info, , KBA , LOD-SF-EC-CMP , Compensation Information & One-Time Bonus , LOD-SF-INT , Integrations , Problem
Product
Attachments
Pasted image.png |