Symptom
You are receiving an error message while posting outgoing bank transfer.
ID PQR of bank details for customer or supplier do not exist
(Here PQR refers to the Payee bank)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Liquidity Management work center.
- Go to the Common Tasks view > New Outgoing Bank Transfer.
- Enter all the mandatory data.
- Select required Payee Bank PQR.
System throws error message: ID PQR of bank details for customer or supplier do not exist
Cause
The reason for the error message is that the payee(supplier) bank account is not valid for the Outgoing Bank Transfer Document Date and Posting Date.
Resolution
There are two options to overcome the error message:
1) Change the Outgoing Bank Transfer Document Date to a date equal or after the Supplier Bank Account Valid From date.
2) Change the Supplier Bank Account Valid From date to a date equal or before the Outgoing Bank Transfer Document Date.
For the second option, the steps to be followed are:
- Go to the Supplier Base work center.
- Go to the Suppliers view.
- Search for the respective supplier.
- Select the row of the supplier and click Edit > Financial Data.
- Go to the Bank Data tab.
- On top, right-hand side, click the user profile picture > Start Personalization Mode.
- Expand Unnamed Table UI Element.
- Tick Valid From to make it Visible (the Valid From field is hidden by default so you need to make it visible).
- Click Save.
Now you can change the Bank Data validity as per the Document and Posting Date.
Keywords
Outgoing bank transfer, bank details for customer or supplier do not exist, Payee Bank, account not valid , KBA , bank details for customer or supplier , outgoing bank transfer error , payee bank , bank data validity , SRD-FIN-MOP , Payment Management , Problem