Symptom
The Error "Business Partner XXX Already exists" is Raised in SAP S/4HANA Cloud
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Create a new Business Partner e.g. in one of the Business Partner Master Data Apps e.g. Maintain Business Partner App or via BP SOAP or API_BUSINESS_PARTNER
- The error "Business Partner XXX Already exists" is Raised
Cause
- If using an Business Partner Grouping which has an External Number Range this error comes when trying to create a BP with a number which has already been used
- If using an Business Partner Grouping which has an Internal Number Range this error comes when the Number Range Status has been set too low.
Resolution
If using an Business Partner Grouping which has an External Number Range
The number has already been used, use another number from the number range
If using an Business Partner Grouping which has an Internal Number Range
- Open the SSCUI 102241 Define Groupings and Assign Number Ranges and find the Number Range assigned to the BP Grouping being used
- Open the SSCUI 102296 Define Number Ranges and check the Number Range status,
- Press the "Number Level" button
- Set the Number Range status to be at least the last used BP in the number range
4.1 Examples of how to find the highest BP number on the BP Grouping? you can for example use I_BUSINESSPARTNER view, use the Export Master Data App to check BUT000 or simply use the Grouping Filter in the Manage Business Partner Master Data app to see all the BP's created with that Grouping so far.
Keywords
SAP S/4HANA Cloud, S4_PC, S4_1C, X4BC, S4HC, S/4HC, Business partner &1 already exists,, Business partner already exists, SSCUI 102241 Define Groupings and Assign Number Ranges, SSCUI 102296 Define Number Ranges, /CPD/CL_MSG113, FLBP323, FSBP_MAIN_ERROR_MSG004, ICL_MINI_BP212, PLM_QUEST026, R1286, RFM_SITE_MASTER004, /CPD/CL_MSG 113, FLBP 323, FSBP_MAIN_ERROR_MSG 004, ICL_MINI_BP 212, PLM_QUEST 026, R1 286, RFM_SITE_MASTER 004 , KBA , LO-MD-BP-ODT , OData Service for Business Partner , How To