Symptom
During creation of new validation, you notice there is one or more rules missing for selection.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service Workcenter
- Enter Tickets View
- Click on + to create a new one
- Start adaptation mode
- Navigate to Implementation
- Click on Rules and Validations
- Click on Add
- Select Validation
- Result: You notice that rule X is missing
This is just an example. This behavior can happen in others screens.
Cause
The rule that is missing is of value type.
Resolution
The rules available for validation are only the ones of property type.
See Also
Create and Assign Rules - Help Documentation
Keywords
UI Rule, Validation, Rule Missing , KBA , AP-RC-UIF , C4C UI Framework , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2205