SAP Knowledge Base Article - Public

3242790 - Pay Component values passed from RCM were not reflected in New Hire Data Review - Onboarding

Symptom

  • Pay Component Configuration
  • Pay component Values not passing from RCM to Onboarding

Environment

SAP SuccessFactors Onboarding

Cause

  • Values not flowing from RCM to Onboarding
  • The Pay component code is incorrect (missing)
  • Candidate initiated from RCM but did not land in Onboarding dashboard

Resolution

Configuration steps:

  1. Enable compInfo, payComponentNonRecurring and/or payComponentRecurring data model as per your requirement from Manage Business configuration
  2. You can enable all the three data models or any two or one as per the requirement. Enable the fields for which you want to pass the value from RCM side.
  3. Use the Recruit to hire data mapping tool to Map the Pay component fields from RCM to EC fields
  4. Use the following links to map data from Recruiting Management with Employee Central Entities:

Reference:

Note:

  1. Pay Component field should be text in RCM. The object type is not supported.
  2. Earlier it was mandatory to map Pay component from RCM to Onboarding but after the recent enhancement it is not mandate.  
  3. Check the guide link on the enhancements made to the Pay component mapping in Recruit to hire data mapping tool (R2H) :Enhanced Recruit to Hire Data Mapping Process | SAP Help Portal

Permissions Required: 

  1. User -> Employee Central Effective Dated Entities -> Select the options that best fit your requirements (Determines which effective-dated fields can be viewed or edited)
  2. User -> Employee data -> Select the options that best fit your requirements
  3. Refer Guide link for more information on permissions: Role-Based Permissions for New Hire and Internal Hire Data Review - SAP Help Portal

For cause 1: Values not flowing from RCM to Onboarding

    1. There are 2 possibilities: -
      1. Need to check if data is getting passed from RCM to ONB
      2. Need to check if any rule is configured on EC entities (Manage Business Configuration) that is clearing the field values

Approach for Step 1: if data is getting passed from RCM to ONB

  1. We can use Suite Integration Test Tool to fetch what data was passed from RCM -> ONB
  2. Please refer the KBA: 3579652 - An application error occurs while extracting data from the Suite Integration Tool.
  3. Go to request parameters
  4. find candidateId, applicationId and JobReqId for the candidate.
  5. Request example:           {

                   "candidateId" : "216",

                   "appId" : "270",

                   "reqId" : "154",

                   "onboardingId" : ""

                }

  6. Click on Get Data from RCM Or ONB and will get Json Response.
  7. Verify if data is flowing getting passed from RCM or not.

    Use the guide link for more details: Checking the Values Passed from Recruiting to Onboarding | SAP Help Portal

    For cause 2: The Pay component code is incorrect. We can have two scenarios here: 

    • Scenario 1: all fields are blank
      • Variant Code contains space or other special character.
        Currently the application doesn't support special character except for digits, letters and hyphen like: [0-9a-zA-Z-]+
    • Scenario 2: only one or two fields are blank
      • Some rules on Pay Component would block the data.
    • Resolution for Scenario 1:
      • Select a proper variant with only digits, letters and hyphen in Recruit-to-Hire Data Mapping.
    • Resolution for Scenario 2:
      • In the Manage business configuration check for any rules configured that defaults the Pay component data and disable it

    For cause 3: Candidate initiated from RCM but did not land in Onboarding dashboard

    Please refer the KBA for complete troubleshooting: 3064169 - [Onboarding] Candidates do not appear in onboarding dashboard after initiation from RCM - SAP for Me

    Error found in Business Process tile like: An error occurred while saving the HRIS data for the user 123456 due to the following reason: {"responsePayload":[{"userSysId":"123456","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"PayComponent - 123 :: frequency cannot be empty for pay component 123."}]}]}.

    Checked suite page and value and mapping is maintained in RCM.

    The frequency passed from RCM is picklist whereas the Frequency is object in EC. Please make sure RCM is sending Frequency Id.

    KBA reference: 3210979 - Error "frequency cannot be empty for pay component XXX", although value and mapping is maintained in RCM - SAP for Me

     

    See Also

    Related KBAs:

    Keywords

    Pay component, Compensation, Onboarding, compInfo, Paycomp recurring, Pay component Recurring, OBX, RCM, value, payComponentNonRecurring, Permission, OBX , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , LOD-SF-OBX-RHE , Recruit to Hire Tool , Problem

    Product

    SAP SuccessFactors Onboarding all versions