Symptom
When you search for the candidates in a talent pool, you may face this error:
"Your search was unsuccessful. The system cannot find the country/region picklist using the user's country/region and was unable to derive the country/region from the Territory Entity object using the country/region picklist option ID from User Information. Please contact your administrator to make sure the country/region picklist exists, and Territory View is not missing or corrupted."
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Access the instance;
- Go to Recruiting tab;
- Go to Candidates tab;
- Select the Talent Pool tab;
- Click to search candidates using the talent pool.
Cause
The country configured for the current user (UDF) do not corresponding to the official code according to ISO (to get the complete list see the link here, select country code option).
Resolution
Download your UDF file, check the current value for the field Country in the employee data and if it's needed, adjust for the correct value.
Keywords
rcm, talent, pool, candidate, search, error, territory, UDF, file, country, code, ISO , KBA , LOD-SF-RCM-CRM , Candidate Relationship Management , Problem