Symptom
You expect that the "Initial Response By" and "Completion By" are showing the value of date in the Report: Service Request. However, it only shows the status value and not date in the report.
Environment
SAP Business ByDesign
Reproducing the Issue
- Open Report: Service Request (CRMSRQHB_Q0019).
- Search for Service Request ABC (where ABC represents for service request ID).
- Add the field "Initial Response By" and "Completion By" as Row fields.
- You can see the field "Initial Response By" and "Completion By" are showing the value as "Compliance Check Pending".
- Open Service Request: ABC.
- "Initial Response By" and "Completion By" are showing the value as dates.
Cause
The fields "Initial Response By" and "Completion By" are actually status values and not dates in the report. This is different from the value in service request. Hence the status description is showed on the report and datasource. No due dates exposed on the data source, so you would not be able to view them.
Resolution
You can follow the below steps to check the AgreementComplianceCode Codelist of "Initial Response By" and "Completion By" status values:
- Go to Business Analytics Work Center - Data Sources View.
- Click Documentation.
- Click [Download Codelist] of AgreementComplianceCode for the fields "Initial Response By" and "Completion By".
You can see AgreementComplianceCode Codelist as below:
Language; Code; Description
1; "1"; "Compliant"
1; "2"; "Not Compliant"
1; "3"; "Compliance Check Pending"
E; "1"; "Compliant"
E; "2"; "Not Compliant"
E; "3"; "Compliance Check Pending"
If you would like to view due dates of "Initial Response By" and "Completion By" in the report, please kindly submit an influence request, based on the response we receive from other customers we would work on this feature in future releases.
SAP Business ByDesign ( https://influence.sap.com/SAPByDesign)
Keywords
Service Request, Initial Response By, Completion By, AgreementComplianceCode, status , KBA , SRD-CRM-ACT , Activities , Problem