Symptom
You are unable to add a row to the Calendar Relevant Task Category feature inside the Administrator work center. You added the Enable Tasks in Calendar business configuration scoping element to your project.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: you have to enable tasks for Calendar --> Path: Business Configuration > Implementation Projects > Select your project > Navigate to Edit Project Scope > Questions > Sales > Account and Activity Management > Activity Management > Scoping question: Do you want to start using tasks in Calendar? (save and finish the project).
- Go to the Administrator work center.
- Open the General Settings work center view.
- Click in the Calendar Relevant Task Category hyperlink.
- Click in the Add row button.
You will see message 'Your entries have been saved' but line item added is read only.
Cause
You need to enable 'Inline Editing in Browser' and 'Editing in Dataset' of Company Settings for this feature to work too.
Resolution
- Click in the Profile Menu icon (upper right corner).
- Select the Settings option.
- Click in the Company Settings.
- Switch on the 'Inline Editing in Browser' and 'Editing in Dataset.
- Click in the Save button.
See Also
- Help Portal: Scope and Configure Calendar > Configure Calendar Relevant Task Category
- KBA 3211138 - Problem with Calendar: Cannot See Objects (Appointments, Tasks, Visits)
Keywords
Calendar Relevant Task Category ; Unable ; Cannot ; Add Row ; Read-Only; Grayed-out ; Your entries have been saved ; , KBA , LOD-CRM-CAL , Calendar Control , How To