SAP Knowledge Base Article - Public

3244381 - Users unable to reset their password via link in the email notification

Symptom

Users unable to reset password following the link in the Password Reset email they receive from SuccessFactors. The hyperlink just redirects to the login page.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  • User does "Forgot Password" from the SuccessFactors login page.
  • Receives the password reset email from the application.
  • Clicks on the password reset hyperlink in the email.
  • Gets redirected to SuccessFactors login page instead of the password reset page.

Cause

This can happen when the Password policy for the SuccessFactors tenant is set to "Reset passwords using security questions accessed through email link" in the Password & Login Policy Settings page.

The token in the email template "Reset Password Support Notification based on Knowledge Based Authentication" in E-Mail Notification Templates page is [[DIRECT_RESET_PASSWORD_URL]], which is used for "Reset passwords using security questions accessed through the system" setting.

Because of this disparity, the link in the email doesn't work

Resolution

If the requirement is to continue using [[DIRECT_RESET_PASSWORD_URL]] token in the email template.

If users don't have security questions set before, please switch to "Reset passwords using security questions accessed through the system" in the Password & Login Policy Settings page .

Then upon next login, users will be forced to set security questions. After that, if users click "Forgot password" from the SuccessFactors Login page, they will be redirected to reset password page to answer security questions and then reset their password.

If the requirement is to continue using "Reset passwords using security questions accessed through email link" setting in Password Policy.

Step 1: First please switch to "Reset passwords using security questions accessed through the system" in the Password & Login Policy Settings page.

Step 2: Then switch back to "Reset passwords using security questions accessed through email link" in the Password & Login Policy Settings page. As a result, upon next login, users will be forced to set security questions.

Step 3: Go to the E-Mail Notification Templates page, find the email template "Reset Password Support Notification based on Knowledge Based Authentication", and replace the token  [[DIRECT_RESET_PASSWORD_URL]] with [[RESET_PASSWORD_URL]].

After this, users who have defined their own security questions after Step 1, can then click "Forgot password" from the SuccessFactors Login page. This will trigger email to them with the reset link, and the link will redirect to reset password page where the user can answer security questions and set the new password.

Keywords

Password,Reset,Email,Hyperlink,Redirection,Login , KBA , LOD-SF-PLT-PWD , Password Policy Settings & Reset Password , Problem

Product

SAP SuccessFactors HXM Suite all versions