Symptom
You have an issue where the Donut View is not working properly/displayed as expected for Work Tickets.
In this case, the description of the field is not returned, only the ID.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log into Customer System;
- Go to Service WC;
- Go to Work Tickets;
- Select Donut View;
- Here you will notice that the Donut Chart for "Service Technician", for example, does not display the description of the field, but the ID.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Cause
The description is not returned. Therefore only the ID will be available on the Donut chart.
So, it will display descriptions only if this field is also part of the output list (meaning, only if there is a corresponding column in the resultant list for this).
Currently this is system behavior.
Resolution
This is the current system expected behavior.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:
Keywords
system behavior; donut chart; ID; description; ticket view; service. , KBA , AP-RC-UIF , C4C UI Framework , Problem