SAP Knowledge Base Article - Public

3244880 - phoneCountryCode and optInCellNumber not displaying in Quick Apply screen - Recruiting Management

Symptom

When a candidate tries to apply to a job requisition where Quick Apply is enabled, the fields phoneCountryCode and optInCellNumber are not displaying for the candidate to fill them out. The fields do appear in a regular job application and on the candidate profile as well.

Environment

SAP SuccessFactors Recruiting Management

Cause

Quick Apply uses a combination of the 5 always required fields from the candidate profile (firstName, lastName, country, cellPhone and primaryEmail) as well as the job application fields to display in there. Since the fields phoneCountryCode and optInCellNumber only pertain to the candidate profile template, they do not display in the Quick Apply screen.

Resolution

As of now, this is the system designed behavior for Quick Apply as this tool is supposed to only show the 5 always required fields from the candidate profile and the job application template fields. Since these fields are not supported in the job application template, they will not display in job applications using Quick Apply.

If you believe having such functionality would be a good feature for Recruiting Management module, please submit this idea to our Influence Page, where you can submit an idea or search and vote for existing ideas that you consider relevant in the Influence Page, so they can become an enhancement for future product versions.

The following KBA addresses how to submit Enhancement Requests: 2090228 – How to submit enhancement requests for SAP SuccessFactors products.

Keywords

quick, apply, tool, feature, job, application, template, app, req, requisition, candidate, profile, phone, mobile, sms, text, message, messaging, field. , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions